MyPost

NetCommons3のインストールで内部エラーが出る

最近ちょこちょこお客様から引き合いをいただくので、インストールを何度もやっているんですが、毎回毎回忘れるので備忘録も兼ねてここでちゃんと書いておこうかと思いました。

 

えとね、

 

 

PHP.7.2以上ではインストールできません。

 

 

というのは、エラーログの内容見るとね、

 

mod_fcgid: stderr: PHP Fatal error: Cannot use 'object' as class name as it is reserved

 

ってのが出てるので、なんか変数被ってるとかそんなんだろね。うん。たぶんね。

 

で、php7.1.18とか、PHPバージョン切り替えの設定とかで下げてあげるとうまくいきます。

ちなみにインストール後にPHP7.2に戻してもとりあえず動くけど、会員管理のプラグインが内部エラー吐くので、オススメしません。

 

なんかエックスサーバーの新機能で、エックスアクセラレータっていうのがあるんだけど、

Xアクセラレータ Ver.1 静的ファイルの高速化と同時アクセス数の拡張が行われます。

Xアクセラレータ Ver.2 「Ver.1」の特徴に加えて、PHPプログラムが高速化されます。

これのVer.2がね、7.2以上じゃないと使えないんだよね。

せっかくだから使いたい!って思うけどしゃーないね。

 

ということで、NetCommons3を新規インストールする時は、PHPのバージョンを7.1.18などに落としてから行いましょう。

 

0